Help with wiring please (warning lights /hazards)

Post Reply
User avatar
Drake
MMC Member
Posts: 90
Joined: Sat Oct 17, 2015 14:21
Location: Sunny Yorkshire

Help with wiring please (warning lights /hazards)

Post by Drake » Sat Jul 30, 2016 20:36

Hi All,

ANother good day was had on the Cub to the point that I managed to start it for the first time in a couple of years so a major boost. HOWEVER ---

Couple of problems - it is a brand new autosparkes loom. I've connected the white and black wire to the coil but no power at all - i can't see where this connects to without pulling the wiring cover apart which I'm loathed to do. To get it to start I had to power the coil up by a seperate wire ??? it worked but why no power to the white and black one?

As soon as the battery is connected the oil and gen light illuminate irrespective of the ignition switch - as soon as I start the engine they go out as normal (any ideas??)

Finally - as it's the portugese loom that i've used it should be connected to the big hazard switch as fitted to most BL cars of the period. I want to fit a more period looking switch and have purchased a push/pull switch with 3 connectors on the back (plus an earth) Anyone have any ideas how I wire this up? - do i need another flasher unit??

Any help greatly appreciated.

User avatar
Drake
MMC Member
Posts: 90
Joined: Sat Oct 17, 2015 14:21
Location: Sunny Yorkshire

Re: Help with wiring please (warning lights /hazards)

Post by Drake » Fri Sep 09, 2016 14:03

Managed to sort this

Post Reply

Return to “Electrical”